Using InfoPath Forms with SharePoint Workflows

Demo Tips:

1. Open each account in a different browse session so you can show two accounts at one time. Example Jeffrey.giangiulio in
one browser and demomanagerl in another browser.

First Step to using InfoPath Forms with SharePoint is to create a Form Library and Publish
the InfoPath Form to it.

Overview:
» Create SharePoint Form Library to store Expense forms
» Create the InfoPath Form. We will be using the ready-made Expense Report template in Office InfoPath 2007
» Promote certain fields from the form as columns in the form library. Office InfoPath 2007 makes it very easy to publish a form,
promote fields, and even create the form library. All this can be done by using the Publishing Wizard (click Publish on the File
menu).
Procedure:
1. Start Office InfoPath 2007.
2. Inthe Fill Out a Form dialog box, under design a form you will see sample forms. Double-click the sample expense report.
The expense report opens in Design mode. The form already has the fields that you want to promote as columns in the
form library: Name, ID Number, and Total expenses. You will use the template as is.
3. On the File menu, click Save As. We will save the file locally as Expense Report as a backup.
4. On the File menu, click Publish.
The Publishing Wizard opens.
5. Under Where do you want to publish the form template?, click To a SharePoint server with or without InfoPath
Forms Services, and then click Next.
6. Type the address of your SharePoint site, and then click Next.
7. Under What do you want to publish?, click Document Library, and then click Next.

Note that you can also make the form available as a content type. You might want to choose this option, for example, if you

want the make the form template available to all subsites in a portal site.
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8. Under What do you want to do?, click Create a new document library, and then click Next.

9. Type Expense Reports as the name, type a description for the document library, and then click Next.

10. On the next page, click Add.

11. Inthe Select a Field or Group dialog box, in the employee folder, click name, and then click OK.

12. Repeat the previous step twice to add the identificationNumber field (in the employee folder) and the total field (in the

items folder).

NOTE| In the Select a Field or Group dialog box, use the default settings for Site column group and Column name.
Alternatively, you could map the form field to an existing site column or give the column a name different from that of the

form field itself.

13. Click next, verify that the information is correct, and then click Publish.

You now have a form library named Expense Reports with the columns that you need to create workflows
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14. Since we are using a sample form we need to change the Submit Options that were previously set. Under the Tools menu,
click Submit Options.

15. Change Email to Send form data to a document Library.

16. Add a data connection and connect to the document library just created during publishing. Also for this step we will quickly

add a custom formula so that each time a form is submitted it makes a new name.

Sample Formula: concat("Expense Report - “, name, " - ", expenseCode)

Also select the checkbox Allow Overwrite if file exists.
You can choose many onsubmit options from this section
17. Publish the form again.
18. Now go back inside SharePoint update the name displayed when creating a new form:
1. Under the Settings menu, click Form Library settings choose Advanced Settings. Turn Content Types on.
Also if you want the form to open using forms services in the browser select the option to open in browser under

Advanced Settings.
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2. Under the Settings menu, click Form Library settings. Click on the Form Content Type and change the name
to Expense Report. Now when you click the new button it will say new Expense report instead of New form. Much

more descriptive!

Attaching an “Out of the Box” Approval Workflow to the Expense form

Overview:

» Assign an Approval Workflow to All Forms in added to this Expense Report Library
» Run through Approval Process

»  Group the library according to Approval

Procedure:

1. Under the Settings menu, click Form Library settings choose Workflow Settings to Add a workflow.
2. Provide the following Settings on Page 1.

Workflow Select a workflow template: Description:

Select a workflow to add to this document library. If the workfiow template you want does not . | Routes adocument for approval. Approvers

appear, contact your administrator to get it added to your site collection or workspace. Collect Feedback | =nomoveor reject the document,
Collect Signatures =!| reassign the approval task, or request
Disposition Approval + | changes to the document.

Name

Type a unigue name for this workflow:
Type a name for this workflow. The name will be used to identify this workflow to users of this

i Management Approval
document library.

Task List

Select a task list: Description:
Select a task list to use with this workflow. You can select an existing task list or request that a New task list »  Anew task list will be created for use by this
new task list be created, workflow.
History List Select a history list: Description:
Select a history list to use with this workflow. You can select an existing history list or request that Workflow History w  History list for workflow,

a new history list be created.

Start Options

O atlow this workfiow to be manually started by an authenticated user with Edit Items Permissions.
Spedcify how this workflow can be started.

Require Manage Lists Permissions to start the workfiow,
Start this workflow to approve publishing a major version of an item.
Start this workflow when a new item is created.

Start this workflow when an item is changed.

Next ] [ Cancel
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3. Provide the following Settings on Page 2.

Workflow Tasks

Sperify how tasks are routed to participants and whether to alow tasks to be delegated or if particpants can ASSIGn tsks to:
request changes be made to the document prior to firishing thei tasks. ot el e e

& One particpant at a time (serial)
Allow workflow particpants to:
1 Reassign the task to another person
W Request a change before completing the task

Default Workflow Start Values

Specify the default values that this workflow will use when it is started, You can opt to allow the person who ~ T¥P€ the names of people you want to participate when this workflow is started. Add names in the order in which you want the tasks
starts the workflow to change or add participants. assigned (for serial workfiows).

[ Assign a single task to each group entered (Do not expand groups).
' Allow changes to the partiapant list when this workfow is started

Type & message tao indude with your request:

Due Date

If a due date is spedfied and e-mail is enabled on the server, partidpants will receive a reminder on that date if their task is not finished.

Tasks are due by (parallel):

Give each person the following amount of time to finish their task (serial):
z Day(s)
Notify Others

Ta notify other peaple when this workfiow starts without assigning tasks, type names on the CCline.

glcc...

Complete the Workflow

Specify when you want the workfiow to be completed. If you do not select any optians, the workflow will be  Complete this workfiow when:
completed when all tasks are finished. ™ Following number of tasks are finished:

Cancel this workflow when the:
W Document is rejected

™ Document is changed

Post-completion Workflow Activities

Specify the actions you want to occur after the workflow has been successfully completed. After the workflow is completed:
¥ Update the appravsl status (use this workfiow to control content approval)

[oK] [ cancel

Note: Approvers must have approval level permission or above on this Form Library.

3. Additionally you may want to sort the view by approval status. Navigate to View -> Modify this view. Set Sort By to the
Workflow Status Column.

4. Now create a new expense Report and this will kick off the Approval Workflow. The managers listed in the workflow will
be notified for approval

5. Explain how they must have approval permissions or above to approve the workflow.

a. Notice Demomanagerlis only an approver and does not have the doc library settings menu.
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Attaching an Designer Workflow to the Expense Form. This workflow will check if the
expense amount requested exceeds $500.00. If the amount is greater than 500, a specific
manager or CEO will be notified for review.

1. Start Microsoft Office SharePoint Designer 2007.
2. On the File menu, click Open Site.

3. Inthe Open Site dialog box, browse to and select the SharePoint site where you want to create the workflow, and then click

Open.

4. On the File menu, point to New, and then click Workflow.
The Workflow Designer opens.
5. Inthe Give a name to this workflow box, type Expense Report Review.
Site visitors will see this name when they view the Workflow Status and Workflows pages in the browser.

6. Inthe What SharePoint list should this workflow be attached to? list, click Expense Reports.
7. Under Select workflow start options for items in Expense Reports, do all of the following:

= Clear the Allow this workflow to be manually started from an item check box.

=  Select the Automatically start this workflow whenever an item is created check box.

= Select the Automatically start this workflow whenever an item is changed check box.

By choosing these options, you ensure that the workflow runs whenever a team member fills out a new expense report or

modifies an existing report.

Define your new workflow

Choose the type of workflow and the conditions under which this new workflow

Give a name to this workflow:

|Expense Reports Review

What SharePoint list should this workflow be attached to?
|Expense Reports W

Select workflow start options for items in Expense Reports:
] allow this workflow to be manually started from an item

Automatically start this workflove when a new item is created
Automatically start this workflow whenever an item is changed

8. Click Next.
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You want to create a rule where if total expenses reported in the form are greater than 500 dollars, the appropriate person is

notified to review the expense report.

9. Inthe Workflow Designer, click Conditions, then select Compare Expense Report Field .
10. In the condition If value equals value, click the first value hyperlink and set the Value to Total.
11. Inthe workflow rule, click equals, and then click is greater than in the list.

12. Click the second value hyperlink, and then type 500.

13. Click Actions, and then click Send an Email in the list.
If this action does not appear in the list, click More Actions, click the action that you want, and then click Add.

14. In the action Email this message, click this message, and then complete the form by entering the recipient, subject, and body

text of the message.
For the recipient, choose the person who must review the expense report.

You can also add any lookups you wish such as the url to the Report.

Example Text:
Please review the following Expense Report.

http;//mossdev:8091 <url path variable.

15. Click OK.

Workflow Designer - Expense Reports Review

Step Mame: |Step 1

Specify details for "Step 1°

Choose the conditions and actions that define this step of the workflow:

If Expense Reports:Total is greater than 500.0
Email the reviewer

You now have a rule where if an expense report is created or changed in the Expense Reports library, and the total expenses for

that report are greater than 500 dollars, the correct person is notified to review that report.
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16. To check the workflow for errors before you exit the Workflow Designer, click Check workflow.

If there is a workflow error, the hyperlink changes color and asterisks appear before and after the invalid parameter. In addition,

under Workflow Steps, an error symbol appears next to each step that contains an error.
17. Click Finish to save the workflow.

To test the workflow, browse to the Expense Reports library, click Fill Out This Form to create a new item, and make sure that
you enter expenses greater than 500 dollars. Save the form to the form library, and then check to see if the designated person

receives the message that you created.
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